Wir bieten MS Excel Kurse in München und Bayern

Beispiel WENN Funktion – MS Excel Kurs

Mit WENN-Funktionen können Berechnungen in Abhängigkeit einer Bedingung durchgeführt werden.
Diese Funktion wird häufig auch als „
Wenn-Dann-Sonst-Funktion“ bezeichnet.

Funktionsweise: WENN Funktion

=WENN(BEDINGUNG;DANN;SONST)

Wenn die BEDINGUNG erfüllt ist, DANN
Wenn die BEDINGUNG NICHT erfüllt ist, SONST
Textangaben stehen in „Anführungszeichen“
Trennung durch Strichpunkt
Keine Leerzeichen verwenden

Beispiel: WENN Funktion (IF-Function)

Wir wollen die Wenn Funktion anhand eines klassischen Beispiels erklären.
Beispiel: Bonuszahlung Mitarbeiter

Grafik Excel Wenn Funktion - Bild 1

Mit Hilfe der WENN Funktion soll „automatisch“ eine mögliche Bonuszahlung für die jeweiligen Mitarbeiter ermittelt werden. In unserem Beispiel bekommt jeder € 500.- Bonus, sofern der Umsatz im Juni größer oder gleich € 40.000.- war, ansonsten bekommt er € 0.- Bonus.

Grafik Excel Wenn Funktion - Bild 2

Dafür wird in E5 die Formel =WENN(C5>=40000;500;0) eingegeben. In Worten ausgedrückt bedeutet die Formel: Wenn (=WENN) der Umsatz in C5 gleich oder gößer € 40000.- ist (C5>=40000) dann (;) erhält die betreffende Person einen Bonus von € 500.- (500) ansonsten(;) erhält die Person € 0.- (0). Der errechnete Wert wird in dem Feld mit der Formel ausgegeben.

TIPP – Logische Operatoren für die Erstellung von Bedingungen

  • < kleiner
  • > größer
  • = gleich
  • <> ungleich
  • <= kleiner gleich
  • >= gößer gleich

 

Weitere Tipps und Tricks zur WENN-Funktion: WENNS-Funktion mit MS EXCEL

 

Wie kann ich mit der WENN-Funktion in MS Excel ganz einfach bestimmte Bedingungen für meine Daten festsetzen?

Sie wollen zum Beispiel eine Datei erstellen, in der Sie Ihre Kundenrabatte festlegen. Hierzu eignet sich am besten die WENN-Funktion, die immer aus drei Schritten besteht:

WENN, DANN, SONST.

Ihr Kunde XY bekommt beispielsweise 10 % Rabatt wenn er mehr als 500 Euro Umsatz generiert hat, falls er darunter ist, bekommt er die 10% Rabatt nicht.

 

Wie kann ich eine geschachtelte Wenn-Funktionen in MS Excel am besten fehlerfrei nutzen?

 

Die WENN-Funktion in MS Excel eignet sich besonders, um einen logischen Vergleich in MS Excel zwischen einem aktuell bestehendem Wert und einem erwarteten Wert zu ziehen.

Mit der WENN-Funktion lässt sich also überprüfen, ob eine bestimmte Bedingung besteht und ob ein erwartetes Ergebnis herauskommt, wenn man den Wert „Wahr“ oder „Falsch“ untersucht. Erwarten Sie aber beispielsweise mehrere Ergebnisse, kann es durch mehrere „Verschachtelungen“ in der Formel zu fehlerhaften Ergebnissen führen.

Wenn A1=4000 ist, soll also ein Bonus gezahlt werden. Tritt A nicht ein, soll Fall B eintreten, das heißt, es gibt keinen Bonus. Soweit ist die WENN-Funktion ja logisch und klar.

Wie soll man aber vorgehen, wenn man für A eine weitere, zweite Bedingung prüfen möchte, und dann der Fall C eintreten soll. Im konkreten Fall bedeutet dies dann: WENN A1=4000 DANN Aktion A SONST WENN A1=7500 DANN Aktion C SONST Aktion B. In den SONST-Bereich der ersten WENN-Funktion wird hier also eine zweite WENN-Funktion und zugleich eine zweite Bedingung, eingebettet.

Um hier Fehler zu vermeiden, können Sie die WENNS-Funktion nutzen, die nun, sozusagen als Erweiterung der WENN-Funktion in MS Excel, verfügbar ist. Der Vorteil für Sie liegt darin, dass Sie sich keine komplexen Gedankengänge mehr über die WENN-Anweisungen und die dazugehörigen Klammern machen müssen. Somit sparen Sie Nerven, mögliche Fehler und vor allem Zeit. Die WENN-Funktion

 

=WENN(A1>89;“A“;WENN(A2>79;“B“;WENN(A2>69;“C“;WENN(A2>59;“D“;“F“))))

 

Kann beispielsweise ganz einfach durch folgende WENNS-Funktion ersetzt werden:

 

=WENNS(A1>89;“A“;A2>79;“B“;A2>69;“C“;A2>59;“D“;WAHR;“F“)

 

Allerdings sollten Sie auch hier nicht zu viele WENNS anwenden, damit die Erstellung, das Testen und die Überprüfung, bzw. eine möglicherweise anfallende Korrektur, nicht zu viele Komplikationen hervorruft. Ratsam ist es, eine überschaubare Anzahl an Bedingungen in der richtigen Reihenfolge in Ihrer MS EXCEL WENNS-Formel anzugeben.

Email this to someoneShare on FacebookShare on Google+Tweet about this on Twitter